Watchdog - X Login Outage – Incident details

All systems operational

X Login Outage

Resolved
Operational
Started 10 days agoLasted about 4 hours

Affected

X Bot

Major outage from 2:52 PM to 6:51 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

    Post-mortem: X's login system was not allowing the bot to authenticate due to some recent changes to rate limits. A fix was deployed to improve auth reliability and the bot is now working again. Telegram, Discord, Reddit integrations were unaffected.

  • Identified
    Identified

    Watchdog is not able to log into X due to an issue related to X's login system, so the bot is not able to log in or perform any moderation tasks. We are currently investigating this incident; the next update will be as soon as the outage is resolved.